Kruvalig blog

Июль 28, 2007

Проблемы при настройке Mustek 1200CP

Filed under: bugs — kruvalig @ 6:43 дп

Возможно сканер не работает из за того что кривые родные FC7 rpm
попробую скомпилировать из src ftp://ftp2.sane-project.org/pub/sane/sane-backends-1.0.18/
при компиляции в дистрибутиве не оказалось sane-mustek_pp удалил…
поставил старый rpm из дистрибутива fc7,
на команду:
[root@kruvaligFC7 ~]# scanimage
bash: /usr/local/bin/scanimage: Нет такого файла или каталога
оказывается он находится в:
[root@kruvaligFC7 ~]# /usr/bin/scanimage -L
device `v4l:/dev/video0′ is a Noname LifeView FlyVIDEO3000 virtual device
при компиляции sane устанавливалась в /usr/local…

Запустил снова ./configure
посмотрел вывод оказалось что
*** disabling MUSTEK_PP backend (failed to find libieee1284 library
*** and parport-directio is disabled)
после запуска в системе:
[root@kruvaligFC7 ~]# libieee1284_test
Found 3 ports:
0x278:
0x378:
0x3bc:

0x278: inaccessible
0x378: inaccessible
0x3bc: inaccessible
получается порты недоступны…
http://cyberelk.net/tim/libieee1284/index.html — The libieee1284 homepage

Mustek 1200CP в Fedora Core 7

Filed under: Worked — kruvalig @ 6:37 дп

Проблема решена
итак:
1.
vim /etc/sane.d/dll.conf
# mustec_pp <— раскомментировать эту строку.
2.
vim /etc/sane.d/mustek_pp.conf
# scanner Mustek-1200CP+ 0x378 cis1200+ <— раскомментировать эту строку.
3.
vim /etc/ieee1284.conf
Добавить следующий текст:

# Needed for mustek_pp and some other parallel port Sane backends
disallow method ppdev

4.Можно запускать xsane

Июль 26, 2007

VPN Fedora Core 7

Filed under: bugs — kruvalig @ 10:43 пп

Решил вспомнить что такое Linux.
Выбор пал на Fedora Core 7.

Есть проблемы с VPN соединением,
в WindowsXP по инструкции моего провайдера достаточно
было создать VPN соединение,
на вкладке General указать Host Name 10.84.76.2,
дальше на вкладке Security снять флажок с Require data encruption.
В параметрах соединения устанавливается:
имя пользователя и пароль с карточки.
Вот параметры соединения:
w01VPN
вывод команды route PRINT
w01routePRINT

В линуксе настроил соединение в kvpn

Тут хорошо видны айпишники клиента и сервера.
Так что вроде все работает.
01KVPNC1
Но опера выдает вот что:
02OPERA
посмотрел route
03route
пропинговал все айпишники, все нормально, достижимы.
04ping
наконец tracert xxx, тоже все нормально.
05tracert
на всякий случай сетевые интерфейсы loopback
06Interface_lo
и eth1
07Interface_eth1
Вывод, на сегодня, что то в настройках route
нужно править.

Создайте бесплатный сайт или блог на WordPress.com.